INTERNAL: ERROR: Batch Out of Balance on new TSYS Level III front end networks

Last Updated: December 11, 2020

What's in this article?

Product
Sage Virtual Terminal

Description

*An update to resolve this issue is tentatively scheduled for deployment on June 26, 2017.*


Under the Batch Management menu, select either Credit Card or Purchase Card, then click SETTLE CHECKED TRANSACTIONS.

The Batch Close pop-up window will launch and display the totals of either the Credit Card or Purchase Card batch, whichever was selected.  Click REVIEW COMPLETE, CLOSE THE BATCH DETAIL LISTED ABOVE.

The Batch Close Result will come back with the error "Batch Out Of Balance."  If you review the totals, you will see that they include both the Credit Card and the Purchase Card batch totals.  This differs from the totals listed during the review, which is why the error is displayed.

Cause
The newest TSYS Level III front ends (TSYS20163.[Retail/MOTO/eCommerce]PCL3) have deployed a batch consolidation process that will settle the credit card and purchase card batches as a single settlement.  The VT4 interface was not updated to account for the combined batches. It identifies only the items in the Credit Card or Purchase Card batch as being part of the settlement, but the gateway is actually attempting to close both batches together.

Resolution
Change the front end network to Vital[Retail/Moto/eCommerce]PCL3.2 and then process the settlement.

Alternately, settle in Sage Exchange or Payment Center, or use automatic settlement instead of manual settlement in Virtual Terminal.

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